Can't get the Unity tutorial to work - no meta file in an immutable folder

Hi, I’m following the instructions on this page Developer Hub | Haply to get started. Unity version 2021.3.9f1

But when I add the haply package, I get 3 errors. Have tried continuing with these errors but as soon as I hit Play Unity freezes.

Have tried starting again and using earlier versions of the package but get the same errors.

Any ideas?

Hi Gary! Thanks for reaching out.

I see you’re having some trouble with the Haply package in Unity. The ‘no meta file’ errors are usually not a big deal and shouldn’t mess up your project, but I totally get that you want to make sure.

To help us sort this out, could you send over the Editor.log file? You’ll find it in %localappdata%\Unity\Editor. This will give us more details about what’s going on.

As for those errors, you might want to give the [email protected] package a shot. We’ve fixed the no meta file issue in that version.

To switch to the new package, import the [email protected] package by choosing Add package from tarball in the Unity Package Manager.

Please let us know if this resolves the issue, and feel free to reach out if you have any more questions or concerns.


I don’t get the meta file errors if I import from the tarball file. However, it still freezes as soon as I hit Play and I have to kill Unity off using Task Manager. If I disable the Haptic Thread component it doesn’t freeze.
I have installed the sample scene ForceAndPosition and have the same issue.

BTW the prebuilt sample apps are all working.

How do I send you the editor log? Upload doesn’t accept txt files?


Hey Gary,

You can simply copy and paste the content of the file here and then share the generated link with us.

Additionally, it’d be great if you could provide some more details:

  • How many devices are you using?
  • Are they connected directly to your computer or through a hub?
  • What is the LED state when you plug the device and when you press PLAY.
  • Could you also share the list of serial ports when your device is plugged in? You can do this by following these steps:
    1. Open Windows Powershell as an administrator.
    2. Execute the following command:
    Get-WMIObject Win32_SerialPort

These details will help us better understand your setup and assist you more effectively. Thanks!

Today, it’s decided to work - sort of. It’s not freezing Unity any more although I haven’t changed anything I am aware of. Sometimes I don’t get the device listed in the Device Address in the samples and I have to click Play to populate the list.

I am trying the 4 samples and I can move the cursor around. However, as soon as there is any haptic feedback, the unit just whips round with such force that it takes it out of my hand - it’s quite scary! So I am not sure what is going on there. Also it flashes green rather being solid when playing in the Editor?

The built demos are all still working fine.

  1. One device
  2. Through a hub/breakout box - PC only has USB C ports. I have also tried connecting it using a USB C-USB cable and that doesnt work.
  3. Red. Green when using prebuilt apps. Flashes green when using it Unity Editor.
  4. __GENUS : 2
    __CLASS : Win32_SerialPort
    __SUPERCLASS : CIM_SerialController
    __DYNASTY : CIM_ManagedSystemElement
    __RELPATH : Win32_SerialPort.DeviceID=“COM3”
    __DERIVATION : {CIM_SerialController, CIM_Controller, CIM_LogicalDevice, CIM_LogicalElement…}
    __NAMESPACE : root\cimv2
    __PATH : \AERO_GS\root\cimv2:Win32_SerialPort.DeviceID=“COM3”
    Availability : 2
    Binary : True
    Capabilities :
    CapabilityDescriptions :
    Caption : USB Serial Device (COM3)
    ConfigManagerErrorCode : 0
    ConfigManagerUserConfig : False
    CreationClassName : Win32_SerialPort
    Description : USB Serial Device
    DeviceID : COM3
    ErrorCleared :
    ErrorDescription :
    InstallDate :
    LastErrorCode :
    MaxBaudRate : 115200
    MaximumInputBufferSize : 0
    MaximumOutputBufferSize : 0
    MaxNumberControlled :
    Name : USB Serial Device (COM3)
    OSAutoDiscovered : True
    PNPDeviceID : USB\VID_16C0&PID_0483\13746220
    PowerManagementCapabilities : {1}
    PowerManagementSupported : False
    ProtocolSupported :
    ProviderType : Modem Device
    SettableBaudRate : True
    SettableDataBits : True
    SettableFlowControl : True
    SettableParity : True
    SettableParityCheck : True
    SettableRLSD : True
    SettableStopBits : True
    Status : OK
    StatusInfo : 3
    Supports16BitMode : False
    SupportsDTRDSR : True
    SupportsElapsedTimeouts : True
    SupportsIntTimeouts : True
    SupportsParityCheck : True
    SupportsRLSD : True
    SupportsRTSCTS : False
    SupportsSpecialCharacters : False
    SupportsXOnXOff : False
    SupportsXOnXOffSet : False
    SystemCreationClassName : Win32_ComputerSystem
    SystemName : AERO_GS
    TimeOfLastReset :
    PSComputerName : AERO_GS

It’s good to hear that it’s working somewhat better now.

Regarding the force being too strong when there’s haptic feedback, you can adjust the stiffness to reduce the initial force. In each sample, there is a slider to do this:


Also, to refresh the device list dropdown you can select another scene object and select the haptic thread again (the listing is done on the OnEnable event)

As for the flashing green LED, it’s worth checking if it stops flashing during calibration or if you notice a drop in force synced with the blinking ?

Regarding the USB connection, your serial port list looks good, which is a positive sign that the device is recognized. But if you run into any more issues you should try another USB-C data cable directly connected to your computer without using the hub. This can sometimes resolve connectivity issues.

Just so you know, we’re working on improving our tools, so those things should get smoother really soon.

Hi Jer,

Unfortunately today it’s gone back to Unity just freezing when I hit play. Tried rebooting etc and I have now downloaded the latest Unity 2021.3.33f1 version and tried again but still it just freezes. This is using any of the sample scenes. Should I try another Unity version? If I disable the Haptic Thread component it doesn’t freeze.

I’ve had a look at the Editor Log but I don’t see anything useful.

If the Device Address is not set then I just get loads of ‘Exception: device address not set’ messages but no freeze. Once the Device Address is set then it freezes as soon as I hit play and nothing in the Editor.log.

I don’t think there are any problems with my USB connections as the prebuilt samples are all working fine.


Hi Jer,

I have just tried building a Windows app from the ForceAndPosition sample scene. The first time I built the app the Device Address was not set but I got a scene with the sphere in it - but obviously it didn’t work. I then set the Device Address and rebuilt. This time the the scene didn’t open, just got a black frozen Unity. So basically the same as when I tried in the Editor.

Other than a different computer, is there anything else I can try?


Hi Gray

I am facing the same issue as you, have you found a solution?

Made a post here with more info:


Hi Ward,
I couldn’t get 1.1.6 to work. I see they have now sent you a link to a new preview version which is the only way I managed to get it to work.