Inverse3 Handle not connecting

I am unable to connect to the handle.

Installed the drivers from here:

I did the calibration and the LED fashed twice green.
As described here: Developer Hub | Haply

The Handle is connected to my PC with the included Haply usb-c to usb cable.
I also tried a usb-c to usb-c cable.

Tested two different windows laptops (windows 10 & windows 11)

Device manager:

Windows Powershell:

PS C:\WINDOWS\system32> Get-WMIObject Win32_SerialPort

__GENUS : 2
__CLASS : Win32_SerialPort
__SUPERCLASS : CIM_SerialController
__DYNASTY : CIM_ManagedSystemElement
__RELPATH : Win32_SerialPort.DeviceID=“COM4”
__DERIVATION : {CIM_SerialController, CIM_Controller, CIM_LogicalDevice, CIM_LogicalElement…}
__NAMESPACE : root\cimv2
__PATH : \DESKTOP-VK23U5N\root\cimv2:Win32_SerialPort.DeviceID=“COM4”
Availability : 2
Binary : True
Capabilities :
CapabilityDescriptions :
Caption : USB Serial Device (COM4)
ConfigManagerErrorCode : 0
ConfigManagerUserConfig : False
CreationClassName : Win32_SerialPort
Description : USB Serial Device
DeviceID : COM4
ErrorCleared :
ErrorDescription :
InstallDate :
LastErrorCode :
MaxBaudRate : 115200
MaximumInputBufferSize : 0
MaximumOutputBufferSize : 0
MaxNumberControlled :
Name : USB Serial Device (COM4)
OSAutoDiscovered : True
PNPDeviceID : USB\VID_16C0&PID_0483\14483250
PowerManagementCapabilities : {1}
PowerManagementSupported : False
ProtocolSupported :
ProviderType : Modem Device
SettableBaudRate : True
SettableDataBits : True
SettableFlowControl : True
SettableParity : True
SettableParityCheck : True
SettableRLSD : True
SettableStopBits : True
Status : OK
StatusInfo : 3
Supports16BitMode : False
SupportsDTRDSR : True
SupportsElapsedTimeouts : True
SupportsIntTimeouts : True
SupportsParityCheck : True
SupportsRLSD : True
SupportsRTSCTS : False
SupportsSpecialCharacters : False
SupportsXOnXOff : False
SupportsXOnXOffSet : False
SystemCreationClassName : Win32_ComputerSystem
SystemName : DESKTOP-VK23U5N
TimeOfLastReset :
PSComputerName : DESKTOP-VK23U5N

PS C:\WINDOWS\system32>


I am actually facing two issues, the handle not connecting and the force feedback not working.
The LED light indicates Purple - In use: Unpowered, I thought this was because of the handle not beeing connected.

But yesterday I tried a 3th computer, desktop this time and suddenly the force feedback worked in the demos but the handle was still not connected.

Now today I try again with the same computer (desktop) and now on this PC the LED light is now also purple and no force feedback.

I dont understand how to activate it or what I did differently from yesterday that now the force feedback does not work?

Any help, would be highly appreciated.

‘Unpowered’ made me start thinking, I figured it was my faulty power cable converter US - EU, which was not plugged in correctly and got the force feedback to work.

Now I am still facing the issue of the handle not connecting.


Thank you for the detailed information.

I’m glad that you managed to spot the power converter issue. I’m taking a note to improve our documentation to make it clearer.

With your second update, does the led is still purple? I’m asking since the purple led could mean two things:

  1. Unpowered
  2. Position Control: using position mode instead of by force mode

Now, for the handle connectivity issue, I would need more context to help you.

Have you tried out the demo package already? You can find them here:

If you are trying to interact directly with the devices, there is two way to do so:

  1. HardwareApi
  2. Service

Which one are you trying to use?

Happy new year!

Hi Martin,

After powering the device the LED was not purple anymore.

The handle now works in Unity with the 2.0.0. service. But it’s not showing up in the demos (that is how I was testing the connection):



Hi Ward,

Thanks for the feedback.

I’ll triage the handle detection issue with CHAI3D and let you know once it is fixed.

Best regards,

1 Like


For anyone searching for chai demos working with the VerseGrip handles:

Our latest chai3D demo suite can be found here
→ Not all of the demos use the VerseGrip, but those that do, ex. 23-tooth, should now be working.

Direct link to download exe chai3d demo bundle is here Demo-Bundle