Samples 1.1.6-preview not running in Unity 2021.3.14f1

I cant get the Unity samples to work, editor freezes when entering play mode.

Chai3D demos are working fine for me, except Handle not connecting:

Unity version:

HardwareAPI for Unity
1.1.6-preview (latest)

Method of installing:
Via tarball and samples via package manager.

Number of devices:
1, right handed

Both Handle and Inverse3 are directly connected to my laptop via Haply Usb-C cable (no hub)

Led Status:
On Inverse3: RED

My Inverse3 shows up in the Device Adress dropdown of the Haptic Thread component, the handle doesn’t. The sample “DynamicObjectForce” without handle, also freezes.

Scene runs fine when I disable the Haptic Thread
I am testing with the 3D URP Unity template

Tried Unity 2021.3.33f1 and Unity 2020.3.48f1, same problem.
Also tested the previous release, 1.1.5-preview, same problem.
Editor is now running in admin mode but this did not fix it.

This is the issue I have, this screen seems to last forever:


Thank you for the detailed information.

We are sorry that you ran in this issue. It is a known issue that we haven’t yet been able to reproduce on our side, but that some customer have experienced with this release.

So far, the best way forward to solve the issue is to use the service instead of the HardwareAPI. At the moment, you can find the release candidate for the service here: It will be officially released in the upcoming days.

You will find in the archive:

  1. Haply Inverse Service installer
  2. Haply Inverse Unity package
  3. Haply Inverse Unity Documentation

The documentation mirrors the changes in the pre release and we don’t expect any big changes in the official release. However, it is still a work in progress. Let us know if you find some part of the documentation unclear, it will help us greatly to improve it.

I would be happy to schedule a meeting with you help you solving the issue.

Best regards,


Hi Martin

Thank you for the help! It’s working now in Unity with the new version you uploaded.

Btw the new Service installer doesn’t create a folder with the version name, as the previous installers did.


Hi Ward,

I’m glad that it worked!

You are right, we changed the default installation folder to remove the version in the path to streamline the installation process and make it simpler & more robust.

Additionally, you can find the following information useful:

  1. The service file log can be located at: %APPDATA%\Haply\Inverse.
  2. The tutorials are accessible at: C:\Program Files\Haply\Inverse\tutorials
  3. The technical doc is housed at: C:\Program Files\Haply\Inverse\docs
  4. The C API and C++ API can be found at: C:\Program Files\Haply\Inverse\include

Best regards,

1 Like